Important! Dropping Support for Old Devices

As time advances, so does technology. We’d love to be able to support everyone’s device, giving access to God’s Word on every phone, tablet, and computer out there. But the truth is, managing that type of wide-spread usage would hinder us from enhancing our app in deeper ways.

So, in order to keep growing, we are dropping support for the following devices:

  • Kindle Fire, 2011 (1st Gen)
  • Kindle Fire, 2012 (2nd Gen)
  • Kindle Fire HD, 2012 (2nd Gen)
  • Kindle Fire HD 8.9, 2012 (2.5th Gen)
  • Android devices using Ice Cream Sandwich or older (Android OS 4.0.4 or earlier)

If you are using one of the previously listed devices, we apologize. Starting on October 15, 2017, we will be phasing out these devices, and thus, the following functionalities:

  • Sync
  • Downloading titles
  • Logging-in to your Olive Tree Account
  • Viewing the In-App Store

Once again, we want to thank all of our users for your support and dedication to our app! If you have any questions about this information, please email us at support@olivetree.com. We hope to continue to provide you with the best resources at the best price, inspiring you in your pursuit of knowing God more.

Have more questions? Submit a request